Principal Pc Și Mac E-mailurile sunt sensibile la majuscule și minuscule?

E-mailurile sunt sensibile la majuscule și minuscule?



Există o mulțime de confuzie cu privire la faptul dacă adresele de e-mail sunt sensibile la majuscule sau minuscule. Unii spun că sunt, în timp ce alții susțin că nu sunt. Deci, cine are dreptate? În acest articol vom analiza dacă adresele de e-mail sunt sensibile la majuscule sau minuscule.

E-mailurile sunt sensibile la majuscule și minuscule?

Ce face o adresă de e-mail?

O adresă de e-mail este alcătuită din trei părți - partea locală (cunoscută și sub numele de utilizator), semnul @ și partea de domeniu. Fiecare parte are propriul rol și este supusă propriului set de reguli. Iată o prezentare rapidă.

Conform standardului, partea locală a adresei de e-mail poate avea maximum 64 de caractere și poate fi alcătuită dintr-un set limitat de caractere. Acestea includ litere majuscule și minuscule ale alfabetului latin, cifre de la 0 la 9, punct și caractere speciale. Caracterele speciale includ „[email protected] # $% ^ & * () _- + = [] {} ~. Este conectat la partea de domeniu cu semnul @.

Partea de domeniu poate avea până la 255 de caractere. Poate conține litere din alfabetul latin (atât cu litere mici, cât și cu majuscule), cifre de la 0 la 9 și cratimă. Cratima nu poate începe sau termina partea de domeniu.

Pot fi folosite și simboluri internaționale, deși mai multe despre asta mai târziu.

Este sensibil la majuscule?

Răspunsul corect la această întrebare este atât da, cât și nu. Conform RFC 5321 , partea locală a adresei de e-mail depinde de majuscule și minuscule. Acest lucru înseamnă că, în teorie, [e-mail protected] nu este același lucru cu [e-mail protected].

De exemplu, [e-mail protejat], [e-mail protejat] și [e-mail protejat] sunt, teoretic, adrese de e-mail diferite. Este ușor de văzut cum acest lucru ar putea crea probleme și ar putea diminua experiența utilizatorului dacă un server de mail ar opta să trateze părțile locale ca fiind sensibile la majuscule. Prin urmare, mulți furnizori tratează partea locală a adresei de e-mail ca insensibilă la majuscule.

cum se setează contul Gmail implicit

În ceea ce privește partea de domeniu, RFC 1035 stipulează că este întotdeauna nesensibil la majuscule. Acest lucru înseamnă că îl puteți scrie cu litere mici, majuscule sau orice combinație a celor două, iar e-mailul dvs. va ajunge la aceeași adresă. În mod practic, [e-mail protejat], [e-mail protejat] și [e-mail protejat] sunt aceeași adresă de e-mail.

In practica

În timp ce adresele de e-mail sunt doar parțial sensibile la majuscule și minuscule, este în general sigur să le considerăm ca fiind nesensibile. Toți furnizorii majori, cum ar fi Gmail, Yahoo Mail, Hotmail și alții, tratează părțile locale ale adreselor de e-mail ca sensibile la majuscule. Acestea fiind spuse, ar trebui să verificați regulile furnizorului de e-mail cu care doriți să creați un e-mail.

Legând punctul anterior, RFC 5321 menționat mai sus recomandă crearea de noi adrese de e-mail cu litere mici, pentru a evita confuziile și problemele de livrare.

Pe de altă parte, dacă prietenul sau colegul dvs. are o adresă de e-mail cu o combinație de caractere majuscule și minuscule, este recomandabil să o scrieți așa cum este atunci când le trimiteți un e-mail. În caz contrar, e-mailul nu poate fi livrat. Cu toate acestea, aceasta nu este o problemă cu furnizorii majori de e-mail precum Gmail, Yahoo Mail, Hotmail și alții.

În plus, Gmail nu este sensibil la punctele găsite în partea locală a e-mailului atunci când vine vorba de identificarea contului de utilizator. Aceasta înseamnă că, dacă contul [email protected] există, nu veți putea să vă înregistrați [email protected] sau [email protected]

Internaționalizare

Inițial, adresele de e-mail puteau fi înregistrate numai folosind literele alfabetului latin, numerele și un set limitat de caractere ASCII speciale. Însă IETF (Internet Engineering Task Force) a dezvoltat ulterior reguli și standarde pentru includerea personajelor internaționale.

RFC6530 a fost primul care a inclus și a reglementat utilizarea personajelor internaționale. RFC6531 extins la reguli și standarde. Ulterior, regulile și standardele au fost actualizate prin RFC6532 și RFC6533 .

Acum puteți înregistra o adresă de e-mail utilizând o gamă largă de alfabete, caractere și scripturi. Unele dintre cele mai utilizate sunt caractere latine cu diacritice, alfabet grecesc, caractere tradiționale chinezești, caractere japoneze (hiragana, katakana și kanji), alfabet chirilic, mai multe scripturi indiene, precum și o serie de altele.

Includerea și compatibilitatea cu adresele de e-mail internaționale variază de la furnizor la furnizor. Chiar și unii dintre cei mai mari furnizori nu sunt pe deplin compatibili cu adresele internaționale. De exemplu, Google vă permite să trimiteți un e-mail la o adresă internațională, dar nu vă permite să creați una. Outlook 2016 are o funcționalitate similară.

Concluzie

Spre deosebire de partea de nume de domeniu, partea locală a unei adrese de e-mail este diferențiată de majuscule și minuscule. Acestea fiind spuse, mulți furnizori de e-mail aleg să ignore sensibilitatea la majuscule a părții locale din motive practice și încurajează oamenii să creeze e-mailuri cu caractere mici.

Articole Interesante

Alegerea Editorului

Scrieți-vă propriul joc Raspberry Pi
Scrieți-vă propriul joc Raspberry Pi
Raspberry Pi este o senzație de calcul, dar a fost inițial conceput cu o intenție cheie: să inspire o nouă generație să privească dincolo de console de jocuri, smartphone-uri și tablete și să adopte calea codului. Dacă sunteți în căutarea
Cum să utilizați Bing AI pe Mac
Cum să utilizați Bing AI pe Mac
Pentru a utiliza Bing Chat pe un Mac, deschideți un browser web și vizitați site-ul web Bing. Conectați-vă la contul Microsoft și apoi selectați pictograma Bing Chat. De acolo, urmați instrucțiunile și sfaturile de pe această pagină pentru utilizarea asistentului Microsoft Bing AI pe Mac.
Cum să obțineți componente în Rimworld
Cum să obțineți componente în Rimworld
Componentele sunt elementele de bază ale practic orice folosiți în Rimworld. Dacă joci un joc fără Componente, nu vei ajunge prea departe. Aveți nevoie de aceste articole pentru a construi nave, arme de foc, dispozitive electrice și altele. Dar cum anume
Cum să adăugați un ton de apel pe iPhone 6S
Cum să adăugați un ton de apel pe iPhone 6S
Când vine vorba de personalizarea iPhone-ului, unul dintre cele mai bune lucruri pe care le puteți face este să personalizați tonul de apel. În timp ce personalizarea pe iPhone lipsește în multe domenii diferite, cel puțin suntem capabili să ne schimbăm
Activați Citirea cu voce tare pentru fișiere PDF în Microsoft Edge Chromium
Activați Citirea cu voce tare pentru fișiere PDF în Microsoft Edge Chromium
Cum se activează citirea cu voce tare pentru fișiere PDF în Microsoft Edge Chromium Microsoft Edge Chromium a primit o îmbunătățire a funcției de citire cu voce încorporată. Acum poate fi activat pentru fișierele PDF pe care le-ați citit în browser.Publicitate Această caracteristică nu este nouă pentru aplicația Edge. Omologul său EdgeHTML moștenit îl avea deja disponibil
Google Earth vs Google Earth Pro
Google Earth vs Google Earth Pro
Cel mai probabil ați auzit despre Google Earth. Dar ați auzit vreodată de fratele său mai mic, Google Earth Pro? Acest articol va analiza în profunzime ambele versiuni ale acestui software popular și va explica tot ce aveți nevoie
Ce este nou în Firefox 54
Ce este nou în Firefox 54
O nouă versiune a popularului browser Mozilla Firefox este disponibilă. Versiunea 54 are capturi de ecran, marcaje mobile, o interfață de utilizator rafinată pentru descărcări și procese de conținut multiproces. Reclamă Începând cu versiunea 54, funcția de conținut multiproces (e10s) este activată în mod implicit. Acest lucru îmbunătățește fiabilitatea Firefox, deoarece dacă o filă se blochează, cealaltă o va face